Resolved
This incident is resolved. Task runs are executing normally.
Monitoring
A fix has been deployed and queued task runs are now processing.
Identified
We have identified the cause of the delayed task runs and are rolling out a fix.
Investigating
We are investigating an issue causing some task runs to remain queued longer than expected. New task runs are being accepted, but execution may be delayed.